Connect platform is down

Incident Report for Mercura ApS

Resolved

The server provider has fixed the issue on the node, and the Connect platform is up and running again.
Posted Aug 19, 2026 - 10:16 CEST

Investigating

We have been notified by our hosting provider that the node hosting the Connect platform has a fault. We'll be monitoring closely, and will provide updates as soon as we know more.
Posted Aug 19, 2026 - 09:31 CEST
This incident affected: Connect.